The Secret World: Membership hath its privileges

bike

Yesterday The Secret World switched on its new membership benefits, which meant a few changes for me now that I bought into the grandmaster pack. Actually, it was kind of funny because GMs get all of the loyalty rewards that are otherwise parceled out according to days subscribed from here on out. So when I went into the store, I saw a pile of goods.

It’s all making me very satisfied for springing for GM status. The cosmetics are nice — I like the new bee suit, it’s got a Mass Effect high-tech look to it. But above that, here are my five favorite things from the membership program:

  1. Bank access anywhere — I hardly ever used the bank, since it required an annoying trip back to London. Now I can summon a portable bank wherever I’m at, and that is an inventory blessing to be sure.
  2. The bee scooter (above) and hoverboard — Love this little shiny scooter, although I might be using the hoverboard more because it seems to handle better in cramped places (platforming, etc.). Love having a hoverboard after getting used to one in WildStar. Now where’s my double-jump?
  3. Bee weapon molds — Oh my goodness, I love these so much. I now have an infinite supply of pretty cool-looking weapon molds to cover up some of the lackluster weapon designs. The pistols are pretty sweet.
  4. Bonus XP and bullion — I ran a few quests last night and found myself giddy at all of the extra XP and black bullion from completing them. This will be so, so helpful to my leveling character.
  5. Free anima leaps — OK, it’s not like anima leaps were super-expensive, but free is free and every bit of PAX saved up helps for those future purchases.

On the flip side of all of this happiness is the fact that I’ve been struggling with TSW’s performance lately. My old computer with my old graphics card could run it incredibly smoothly (no lag/hitching). My new one — with either the old graphics card or a newer GTX 950 — can’t get above 30 fps to save its life and often dives down into the teens or single digits. For an action MMO, this is terrible.

I’ve spent days troubleshooting this, trying to figure out what it is about my build that’s causing this lackluster performance. My other games run fine but not as fast as I would’ve expected with a whole systems overhaul. So far I’ve updated drivers across the board, upgraded to Windows 10 on the hope that it might do something, tried every graphics setting in TSW (on low or ultra it gets the exact same frame rate), looked up and tried every workaround on the forums… nothing. DX9, DX11… it’s all the same. Same frame rate every time. It’s so incredibly bizarre that nothing I do makes a single difference, and it’s even stumped my computer technician brother-in-law. If anyone has ideas, please let me know. I feel as though there’s some setting or obvious bottleneck that I’m not seeing, one thing that I could change that would let the game perform as it should.

I mean, it’s playable, just not always enjoyable to play, if you understand.

Advertisements

20 thoughts on “The Secret World: Membership hath its privileges

  1. Aywren February 10, 2016 / 2:02 pm

    Wow, this is very nice! I need to log in and scoop up my rewards!

  2. pkudude99 February 10, 2016 / 2:16 pm

    A common “fix” for stuttering and lagging on higher end machines is to revert to DX9 instead of DX11.

    My pc died last week — burned out the cooling system and my old 550 card. Got a 950 to replace it. Haven’t fired up TSW yet, but was planning to tonight. I’ll let you know if DX9 vs DX11 matters on mine. It very very much did on the old card. Smooth and playable on DX9 then, but DX11 was awful.

  3. Ben M February 10, 2016 / 2:33 pm

    Hey Syp, sounds like you’ve done great troubleshooting so far! If it’s not video card or settings (which sounds like you’ve checked out very well) then check network differences between the two rigs next, it CAN occasionally cause lagging FPS.

  4. aquarionics February 10, 2016 / 3:07 pm

    From memory TSW does a shader compile thing for your graphics card on first launch, so it may need to redo that by deleting the shader.cache files in the game directory.

  5. bhagpuss February 10, 2016 / 3:13 pm

    I have heard this so many times in so many MMOs – people on brand new, stat of the art gaming PCs having terrible problems while duffers like me puttering along on machines that were barely mid-range five years ago play smoothly and comfortably. I’ve always assumed it’s because the developers long ago ironed out all the wrinkles for the ancient technology I’m using but haven’t gotten around to things that were released much more recently. It’s the main reason I still haven’t replaced my PC even though I decided over two years ago that it was time.

    I note that I’m now under the minimum, let alone the recommended, specs for some MMOs coming out this year. I don’t think I would even be allowed to log in to The Division for example. I’m going to have to trade up at some point but I’m not in any rush.

    On the main topic, instant bank access is a weird one. I loved having to go to London to bank in TSW. I like having to make a special trip to use facilities in most MMOs. Of course, once devs give me instant access I use it but I always feel I’ve lost something rather than gained it. I do the same in real life, though. I confused my bank no end by refusing point blank to use internet banking but I actually enjoy making a trip out to go to the branch – it’s a pleasure, not a nuisance, so why would I want to stop doing it?

  6. Mannginger February 10, 2016 / 3:25 pm

    I had an issue after installing my new Nvidia card, seemed it had defaulted a couple of games to adaptive (half refresh rate). Just mentioning it in case you’ve not checked that in the Nvidia control panel

  7. Syp February 10, 2016 / 3:50 pm

    DX9 and DX11 perform the same for me, no frame rate difference whatsoever. It kind of feels like the game is being throttled down to 30 fps for some reason.

  8. Tyler F.M. Edwards February 10, 2016 / 4:11 pm

    I’m actually a little underwhelmed by the new rewards myself, but that’s purely down to personal preference. The outfit is just a clunkier version of my Carapace of the Immaculate Machine, I don’t much care for the Third Age skins, and I already have all the fancy mounts/sprints I need. The bonus bullion and instant banking are pretty sweet, though, and I’m glad to see others enjoying the perks.

    Can’t help you with the tech issues, I’m afraid. Computers make my brain hurt.

  9. DocHoliday February 10, 2016 / 4:54 pm

    I had a similar experience logging in to check things out, and the bank is a nice one – not because of the pain of getting TO London, but the annoyance of getting back. Without any sort of ports (I’m not that far into Tokyo yet) Agartha can be down-right annoying.

    As for tech stuff, I’ve had similar wierdness with games – have you tried full-screen vs windowed as well as making sure there’s no other CPU process running in the background?

  10. Winter (@Winterskorn) February 10, 2016 / 5:18 pm

    Is it possible that the CPU might be hindering the GPU? Or is it of the same quality?

  11. Syp February 10, 2016 / 5:36 pm

    CPU is an intel i5 — just got off the phone with my brother in law and he said that, unless it’s a thermal issue, there should be no way that the CPU is bottlenecking. We’re looking into processor performance just in case.

  12. ironweakness February 10, 2016 / 5:55 pm

    I have no hardware knowledge whatsoever, so unfortunately I cannot offer any advice. (I have been praying that you find a solution though!)

    However I can speak to the member rewards. I purchased the GM pack too, and it was a lot of fun getting everything at once and going through it all. I didn’t have much time to play last night but I logged in anyway just to try my new mounts and look at all the other goodies. I wasn’t sure about hoverboards in this game– I love my motorcycle– but I have to say the one you get for being a member is really nice.

    And I don’t know how to use the weapon skins yet but once I do, I will be. They look really good and I would like to have a different look for some of my weapons. I don’t remember what the pistols look like, but maybe I’ll find a build that uses them just so I have a reason to use the skins.

  13. Syp February 10, 2016 / 7:39 pm

    Part of the weirdness of this problem is that I have the EXACT SAME frame rate whether I’m running low or ultra. Tested on Marvel Heroes, getting 24-30 fps no matter what I set it on.

  14. Syp February 10, 2016 / 7:40 pm

    Iron — Weapon skins are easy to apply, just plop them in the crafting window with the same weapon type, combine, and there you go.

  15. Vagrant Zero February 10, 2016 / 7:55 pm

    Syp, this is a well-known issue. You need to set the Effects graphical setting to 3.8 instead of 4. If I recall this cannot be done in-game (it will jump down to 3 if you try, no decimals). You need to edit it in of the INI files before the game boots. For now simply to test it out, change your Effects to 3 instead of 4 and see what happens. Good luck mate!

  16. Sylow February 11, 2016 / 4:49 am

    Wow! Good to hear that it’s a well-known issue. I spend way too much time in this game, but this is the first time I hear of this. But alas, I very much hope that your fix works for Syp. πŸ™‚

    On the membership rewards:

    – The new pet looks great. Cute mini-chtulluh with hypnotic eyes FTW. πŸ™‚

    – The increase in BBs is noticeable. In the last two days I had the feeling that now it’s possible to progress gear and augments in parallel, instead of having to push back augments.

    – I really like the new armour also shown in the screenshot. Of course I combine it with an adorable backpack, because real soldiers just need plush doll backpacks to show their manlyhood. πŸ˜€

    -The scooter, like all scooters ever created, and even the concept of a scooter, is terrible. [I had my motorbike at the garage last year. They gave me a scooter to get to work on time. But carrying the thing would’ve been the preferable option, except in terms of traveling speed. ] So, if you have access to motorbikes or hoverboards, never touch a scooter. πŸ˜€

    – Bank access matters little to me. I tend to visit the bank twice a week, once before and once after the weekly lair boss tour with my Cabal, and that’s only if we opt for Egypt bosses, as i am the one to store the fragments for bosses from there. Time will tell if the new console will get more use, but i doubt it.

    – The new weapon skins range from “yuck, what the hell” to “awesome”. And tastes obviously differ, as i rate the pistol in the first option, while i see some love for them here. Anyway, as using them is optional and some of them look really great, it’s a huge win for me. (I should not complain about having to choose about several good options. πŸ˜€ )

    For the first time, my “mighty claymore” ( https://sephorassecretcloset.files.wordpress.com/2014/01/ancient-mayan-dagger.jpg ) is in danger of getting a new appearance… πŸ™‚

  17. Syp February 11, 2016 / 9:20 am

    Vagrant — I tried that a while ago, doesn’t make a difference. I can try it again, of course.

  18. pkudude99 February 11, 2016 / 4:26 pm

    Well, I see your tech support post and the other comments you’ve made here and on it, so I don’t think this will help you much, but…

    I logged in to TSW this morning before work. Initially I set it to “ultra” graphics, but shortly after that I crashed to desktop. Before logging back in, I opened my nVidia control panel and told it to optimize the game’s video settings. After logging back in to the game it was set “custom” and was above “high” but not quite all the way to “ultra.” I was in London and there was a bit of hitching here and there, but once I headed out to Agartha and Kingsmouth, it smoothed right out. FPS varied between 45 and 60 at all times, usually in the 55-60 range unless I had a ton of buildings around. Even in London while it was hitching it still reported 52 or higher though.

    This is after I just barely upgraded from a GeForce 550 to a GeForce 950. On the 550 I was lucky to stay above 25 FPS, and I had to run in DX9 mode to avoid stutter/lag. Didn’t see any trouble at all with my new card. I’m also running a 4 year old mobo, 8 GB RAM, and an i5 3.2 GHz processor.

  19. DmonX February 15, 2016 / 10:00 am

    My setup (at least the pertinent parts) are an FX6300 6core CPU and a GTX950.

    No matter what I tried, TSW was running like utter crap.

    After a whole lot of internet research, which didn’t really help, I started testing my own ideas and came up with this.

    Disabling AMDs turbo core tech in the BIOS, which idles down cores in muilti core setups, and disabling the shader cache for TSW through the NVIDIA Control Panel now has me running the game on HIGH settings with VSYNC always on.

    Maybe you can get some help out of this.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s